site logo

Main Index > FAQs > FAQ#17>
1 visitors online
Two month old aquarium that has cycled and It appears cloudy.
Site Forum

 

To add your comments and suggestions about this question please use the Comment Form and I will add all relevant ones to the page. Please no questions as they will not be answered.

 

Q: We have a 46 gallon tank about two months old that has cycled. It appears cloudy. We change 9 gallons of water weekly. Along with one filter(emperor 400 with diamond blend added) each week. At each water change we add nitromax as instructed. Water test show no bad results ( ammonia = o, pH about 7.1)The fish seem not be affected but it does not look good for our viewing pleasure. We have live plants and a piece of driftwood. We try not to over feed. There are about 16 fish in the tank as listed below.

  • 2 angelfish
  • 2 cherry barbs
  • 2 Otis cats
  • 2 Cory cats
  • 4 dwarf gouramis
  • 2 scissor tails
  • 2 platys

Any how what can we do. We even at one time added Crystal Clear with no affect

 

 

Comment: I also had this hazy free-floating algae problem. It lasted about 3 months! Very annoying. Anyway, I made sure to move my aquarium out of direct sunlight (it was right by my patio doors before) and I also bought an undergravel filter. This seemed to do the trick. Don't bother with a chemical that is supposed to clear up hazy water. That didn't work.


 

The following answers came from the message forum:

A: This looks like an algae bloom (eutrophication) to me...this can be caused by a whole host of factors. Nitrate buildup can be the culprit, or if your water contains phosphates (you might want to check this). Over feeding can lead to this sometimes also. Is nitromax a fertilizer...because if it is it could definitely cause something like this since you don't have a whole lot of live plants in there. To get rid of it, you need to cut all light and feeding for a couple days, and it helps to cover the tank and then it should go away...no fertilizer either.


A: I had a cloudiness problem for approx 5 months, I tried everything, the problem turned out to be the pellets I was feeding the fish, my water was greenish/browness, thought it was an algae bloom, I stopped feeding the pellets and now the tank is crystal clear


A: There could be a number of problems that is causing this algae bloom that you are having. You need to cut down on the excess nutrients, which could very well be from the Nitromax that you are adding each week.
Also, I would highly suggest that you try Algone, which is excellent for algae control and nutrient reduction for any aquarium.

 

 

 

 

Navigation

Privacy Policy | Contact Badman's Tropical Fish
Copyright © 1997-2009
All rights reserved. Reproduction of any portion of this website's content is forbidden without written permission.