Topics Topics Search Search      

Badman's Tropical Fish - Archives * General Message Area * Live Plants and Disease??       


 

These questions and answers are for research or archival use only. There is a wealth of information here and I encourage you to search the areas. For the latest information and to join an active forum please click below.
Badman's message forum


Author Message
Top of PagePrevious PostNext PostBottom of Page Link To This Post

Elizabeth Boyd
New Member
Username: plutosangel

Post Number: 2
Registered: 04-2006
Posted on Saturday, April 08, 2006 - 10:02 am:       

Ok, so I'm new the the live plants in my tank.. but the fish really seemed to love the ones I grew at home, so I decided to go out and buy some Swords etc... If you read my post below you'll see that I just lost a fish to dropsy. I'm just wondering if anyone has had a similar experience where you put a new plant into a tank, and the fish suddenly become sick. I've had these 2 bettas over a year. 5 Gallon filtered tank, heater at 78-80 degrees all the time, regular gravel vac etc... They've never been sick before. They both developed a fungus as well. All within a week or so of the new plants. Am I being paranoid? I did wash the plants before putting them in (although I did notice a very small uninvited snail in my previously snail-free tank). Could some fungus or parasites have hitched a ride on these plants? And what do I do with them now?? I'd like to keep them still, I medicated the tank, threw in some extra salt (dont worry, the fish are all in separate hospital tanks right now). Any thoughts? Can I keep the plants people?!!? I've decided to go with 50% water changes for the next couple of days and use salt and the fungus eliminator in the empty tank... will this clean up those plants?
Badman's Tropical Fish - Archives * General Message Area * Live Plants and Disease??       

Quick Navigation Links

 

      Administration